this post was submitted on 18 Jan 2024
1 points (100.0% liked)

Programmer Humor

19423 readers
98 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS
 
top 9 comments
sorted by: hot top controversial new old
[–] 0x0@lemmy.dbzer0.com 1 points 9 months ago (1 children)

I propose a new, more threatening kind of control flow.

do {
  /* something */
} or else {
  /* you don't want to find out */
}
[–] gex@lemmy.world 1 points 9 months ago

Some C++ style guides suggest the following naming convention for functions that crash on any error

OpenFileOrDie()
[–] lung@lemmy.world 0 points 9 months ago (1 children)
[–] Deconceptualist@lemm.ee 0 points 9 months ago (1 children)

I believe that resolves the same as

ain't!(!untrue)

[–] RagingHungryPanda@lemm.ee 0 points 9 months ago* (last edited 4 months ago) (1 children)
[–] elvith@feddit.de 0 points 9 months ago
{
  put(a, "heartache")
  tell(me, "why")
  ain't(nothing)
  {
    put(a, "mistake")
    //...
  }
}
[–] vlad76@lemmy.sdf.org 0 points 9 months ago (1 children)
[–] Darkassassin07@lemmy.ca 0 points 9 months ago (1 children)

if(condition) {#block never used} else {#actually do a thing}

Vs

ifn't(condition) {#actually do a thing}

Vs

if!(condition) {#actually do a thing}

[–] gandalf_der_12te@feddit.de 0 points 9 months ago

vs

if (not condition) {#actually do a thing}