Probably still better than bool a; bool b; int c;...
Programmer Humor
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
Rules
- Keep content in english
- No advertisements
- Posts must be related to programming or programmer topics
Self-documenting code, high contrast… Carry on.
ThisCommentsMakeItSoThatYouHateMeForWritingLikeThisSeriouslyICanNotStopPleaseSendHelp
Would you like a snake to replace your camel?
Best I can do instead is calling it x
.
I don’t see the benefit of this long naming convention...
It still allow bug to exist... like the fact that, with this code, the player can still play with 0 Hp.
Should have been better to put a "if(health <= 0)" instead of "< 0"
Came scrolling for this ^^
This has likely been done intentionally for humour's sake, but take a look at some of the names in Apple's AppKit framework, like https://developer.apple.com/documentation/appkit/nspreviewrepresentingactivityitem
I'm still annoyed with how verbose Objective-C is. Just check out what one has to do to create and concatenate a string. Madness:
NSString * test = [[NSString alloc] initWithString:@"This is a test string."];
NSString * test2 = [test stringByAppendingString:@" This value is appended."];
And god forbid you want to concatenate two things to a string:
NSString * test3 = [test1 stringByAppendingString:[test2 stringByAppendingString:@" Adding a third value."]];